Deviant Login Shop  Join deviantART for FREE Take the Tour
×

:iconxyrus-02: More from Xyrus-02


More from deviantART



Details

Submitted on
April 18, 2013
Link
Thumb

Stats

Views
10,765 (24 today)
Favourites
37 (who?)
Comments
50
×
Hi guys :)

Since I obviously don't have anything better to do this fine day, I sat down and made 94 (!) existing plugins for Apophysis readable for the 64-bit-version of Apophysis 7X (commonly known as 7x64) - I'm talking about almost all of the plugins available as source code on SourceForge.net including my own. I just skipped some odd non-standard ones, those which are built-into Apo7x15 and dc_image. I don't know what else is floating around in outer space so if you note me the source code (*.c), I'd convert some more too.

It cost me an imaginary pack of cigarettes and 90% of my remaining sanity. So here is the download link:

click me!

Please make sure you read the file README.TXT before you send me messages and comments whining about that it doesn't work for you :)
Also, be advised that I just compiled them. I did not test each single one of them. That'll be up to you. Enjoy ;)

Cheers!

PS: If you're still having the final transform bug (FX won't save), there is a patch available for 7x15D: xyrusworx.deviantart.com/journ…

PS2: If you're getting an error message about a DLL missing, you need to download and install this: www.microsoft.com/en-us/downlo…
Add a Comment:
 
:iconsolidmars:
SolidMars Featured By Owner Jan 25, 2014  Hobbyist General Artist
hi, i have an issue. 
i have apo x64 and i  got the latest plugins you uploaded, the curlsp and the post_log pack, when i add them to my plugins i get the fx bug and it doesn't go away until i remove them. any clue what i  can do? 
i have the patch, but it's not making it go away
Reply
:iconxyrus-02:
Xyrus-02 Featured By Owner Jan 25, 2014  Professional Digital Artist
You probably have too many plugins for Apophysis to handle. Did you install the whole plugin pack at once? Please make sure the amount of plugins you are loading is in bounds. It is very rare that a computer can load all.

A different cause can be a heap of troublemakers in the pack. Please check the following threads in the Apophysis dev group:

We are currently analyzing what can be done about this issue. Until then, make sure not too many plugins are loaded, that there are no duplicates with built-in variations (like with crop.dll) and that you remove potentially faulty plugins. curl_sp and pre- / post_log have been tested on multiple machines running different configurations (x86, x64, less and more RAM) and different operating systems (windows 7, windows 8 and MacOS X)

Reply
:iconsolidmars:
SolidMars Featured By Owner Jan 25, 2014  Hobbyist General Artist
yes, i  have the entire pack, but it never caused issues before because i have a strong pc, custom built for graphics. apo takes a bit to load them at start up  (7-10 seconds), but they work fine. 

thank you i'll check the threads, and i did remove them, so apo worked again. 
i'll try to put them in individually once i am done working on the fractal and see what's causing the issue for me. 
Reply
:icongerda1946:
Gerda1946 Featured By Owner Jan 20, 2014  Hobbyist Digital Artist
So I did everything, including the DLL error thing and it still doesn't work.
I go back to the onces I had and will do it with that.
Reply
:iconxyrus-02:
Xyrus-02 Featured By Owner Jan 20, 2014  Professional Digital Artist
Hmm maybe if you could clarify "doesn't work" I might be able to help you out :)
Reply
:icongerda1946:
Gerda1946 Featured By Owner Jan 20, 2014  Hobbyist Digital Artist
Maybe lol. I got the error message and than I installed the thing you had on jour clarifying page.
Then I opened Apo7x15 again and tried to use one of the dc's. And then there was a message about, i think, kernel!
And then it became to difficult so I got the 86 etc out and will work with the ones I already had, almost all of them.
Reply
:iconxyrus-02:
Xyrus-02 Featured By Owner Jan 20, 2014  Professional Digital Artist
Well hrm maybe a screenshot would be helpful next time you get the error message ;)
Also please make sure you are using Apophysis 15D or higher (16) for this pack!
Reply
:icongerda1946:
Gerda1946 Featured By Owner Jan 20, 2014  Hobbyist Digital Artist
Then that is the problem! I will upgrade Apophysis!!!!
Thanks for your help!! :D :hug:
Reply
:iconxyrus-02:
Xyrus-02 Featured By Owner Jan 20, 2014  Professional Digital Artist
De nada ;)
Reply
:iconfardareismai:
FarDareisMai Featured By Owner Jul 24, 2013  Hobbyist Artist
Thanks very much for this; I've been doing a lot of print renders lately and they are invaluable for using with 64bit chaotica. One day I might request a few other plugins compiled in 64bit, but for now this is great!
Reply
Add a Comment: