Deviant Login Shop  Join deviantART for FREE Take the Tour
×

More from deviantART



Details

Submitted on
March 25, 2012
Link
Thumb

Stats

Views
5,547 (1 today)
Favourites
4 (who?)
Comments
10
×
Aaaand another hotfix release. This time, these problems were addressed:

+ Fixed bwraps, pre_bwraps and post_bwraps (potential division by zero) - thanks again, Fred!
+ Added localization support for the curves panel
+ Changed the flame and translation loading/saving code to support and use UTF8 encoding
+ Updated german localization
+ Updated italian localization (with the help of the great lindelokse - thanks!)

You can get the updated localizations from apophysis.xyrus-worx.org. The binary/source downloads are here (and also on the homepage):

Download binaries (32 and 64 bit)


Download source code

Add a Comment:
 
:iconxyrus-02:
Xyrus-02 Featured By Owner Mar 26, 2012  Professional Digital Artist
Oh it runs on LiteStep? :D Sweet! Maybe it was the old compiler (D2005, now using DXE2) which was causing the memory corruption.

Another example of memory corruption is JDownloader (or I think any software which watches the clipboard written in Java) and Photoshop. The problem is ancient but no fix until today...I guess it's depending a lot on the compiler/runtime used.

But glad it works for you :) Now I would like to have a coffee :D
Reply
:iconxyrus-02:
Xyrus-02 Featured By Owner Mar 26, 2012  Professional Digital Artist
Oh alright. I think the red highlight is actually a cell focus. Not a big deal. For most users, it will be blue.
Reply
:iconfengda2870:
fengda2870 Featured By Owner Mar 26, 2012
Oh,I found the answer.
The F8 is occupied by my translate software.
The second is not a serious problem.When I click the "to 1" it will disappear,and not show again
Reply
:icondorianblackheart:
DorianBlackheart Featured By Owner Mar 26, 2012  Hobbyist Photographer
Thank you Xyrus :)

Firstly for another amazing version of Apophysis
Secondly for the fact it runs on LiteStep!!! :D

Almost perfect (no matter how loud I shout, it wont make me a coffee) :P
Reply
:iconxyrus-02:
Xyrus-02 Featured By Owner Mar 25, 2012  Professional Digital Artist
Got it. Thanks :hug:
Reply
:iconxyrus-02:
Xyrus-02 Featured By Owner Mar 25, 2012  Professional Digital Artist
Both weird. For me, the F8 key works. Just tested. And I haven't had the xaos thing red ever. It's not even suggesting that it could happen in the code :confused:
Reply
:iconfengda2870:
fengda2870 Featured By Owner Mar 25, 2012
I find two problem.
1.The color curve hot key 'F8' doesn't work
2.when first open editor window ,in xaos tab ,you will see the 'to 1' vlaue backgroud color is red ,here is the pic.
[link]
Reply
:icondominator60:
DOMINATOR60 Featured By Owner Mar 25, 2012  Hobbyist Digital Artist
wooohoo! :squee:
Reply
:iconzweezwyy:
zweeZwyy Featured By Owner Mar 25, 2012
:highfive: AOK :boogie: Sent you a little tangible thankyou :thanks:
Reply
:iconhyshka:
Hyshka Featured By Owner Mar 25, 2012  Hobbyist Digital Artist
I can hardly keep up myself! Thanks for your hard work! You rock!
Reply
Add a Comment: